phpBB Gallery 3.0.14

These are MODs already released but have had to be updated to the latest version (for whatever reason) to carry on working and installing with Automod.
Forum rules
MODs in this forum have been updated to 3.0.12 and later for any number of reasons; Author too busy/not supporting the MOD, edits etc have been posted somewhere on phpbb.com but are not being applied automatically with Automod; maybe subsilver2 has been added. Whatever the reason, it's why these MODs are here.
User avatar
John
Posts: 205
Joined: 11 Apr 2013, 08:31
Location: UK
Contact:

phpBB Gallery 3.0.14

Postby John » 15 Nov 2013, 12:23

[08-05-2015] Update for 3.0.14:
1 minor edit to includes/session.php, installs fine with Automod
phpbb_gallery_1_1_8.zip
(1.08 MiB) Downloaded 257 times


[26-02-2015] Update for 3.0.13-PL1:
2 minor edits needed for style files, updated version will install perfectly with Automod.
phpbb_gallery_1_1_7.zip
(1.08 MiB) Downloaded 156 times



This is phpBB Gallery for 3.0.12 with just one line changed so it will install with Automod

  • xml updated to 3.0.12
  • minor error fixed
phpbb_gallery_1_1_6.zip
(1.08 MiB) Downloaded 1290 times


Karma
Posts: 7
Joined: 16 Nov 2013, 12:49

Re: phpBB Gallery 3.0.12

Postby Karma » 16 Nov 2013, 12:51

Thanks for doing this, I didnt like to try it because of the error before, will it 100% work?

User avatar
John
Posts: 205
Joined: 11 Apr 2013, 08:31
Location: UK
Contact:

Re: phpBB Gallery 3.0.12

Postby John » 16 Nov 2013, 13:07

Yes, installed it with Automod, no warnings and no problems here: gallery/index.php

Karma
Posts: 7
Joined: 16 Nov 2013, 12:49

Re: phpBB Gallery 3.0.12

Postby Karma » 16 Nov 2013, 13:25

ok ill try it then

Karma
Posts: 7
Joined: 16 Nov 2013, 12:49

Re: phpBB Gallery 3.0.12

Postby Karma » 16 Nov 2013, 14:26

wow Thanks very much indeed this works brill!!

Karma
Posts: 7
Joined: 16 Nov 2013, 12:49

Re: phpBB Gallery 3.0.12

Postby Karma » 17 Nov 2013, 17:14

How do I get pictures to do this like your do?

17

User avatar
John
Posts: 205
Joined: 11 Apr 2013, 08:31
Location: UK
Contact:

Re: phpBB Gallery 3.0.12

Postby John » 17 Nov 2013, 19:18

That's the highslide plugin, have a look here: install-files/ and check the install.xml file for the gallery; you're looking for Contrib: Plugin Highslide JS

Gaz.h
Posts: 2
Joined: 24 Oct 2013, 09:42

Re: phpBB Gallery 3.0.12

Postby Gaz.h » 17 Nov 2013, 19:42

Karma » Yesterday, 15:26 wrote:wow Thanks very much indeed this works brill!!

Was it easy?

User avatar
John
Posts: 205
Joined: 11 Apr 2013, 08:31
Location: UK
Contact:

Re: phpBB Gallery 3.0.12

Postby John » 20 Nov 2013, 20:43

Don't think he's gonna answer, it's easy enough, just follow the instructions ;) If you get stuck just say.

Karma
Posts: 7
Joined: 16 Nov 2013, 12:49

Re: phpBB Gallery 3.0.12

Postby Karma » 25 Nov 2013, 23:35

Gaz.h » 17 Nov 2013, 19:42 wrote:
Karma » Yesterday, 15:26 wrote:wow Thanks very much indeed this works brill!!

Was it easy?

Yes and works great and the plugin :D sorry I took so long :oops:

kimnielsen
Posts: 1
Joined: 24 Dec 2013, 07:11
Contact:

Re: phpBB Gallery 3.0.12

Postby kimnielsen » 24 Dec 2013, 07:22

i thanks too for this great mod (sorry my english danish :) )

i have one problem i dont understand

when i have upload a picture there is nothing in the small window only a red cross

when i hit inside the picture it is there (the picture)

i think it is the thumbnail but im not sure

what is there wrong here

anybody how will help thanks and happy christmas

Karma
Posts: 7
Joined: 16 Nov 2013, 12:49

Re: phpBB Gallery 3.0.12

Postby Karma » 24 Dec 2013, 09:40

Hi, can you post your URL to the forum please.

Casje
Posts: 1
Joined: 23 Mar 2014, 20:36

Re: phpBB Gallery 3.0.12

Postby Casje » 23 Mar 2014, 20:42

I've tried to install the gallery.
Did alle the edits, but when it comes to install from the install folder index.php, i will get a error screen, and i am no longer logged on my forum, and i can't log in to my forum. the install screen show me a database error and it says.."you must be founder to install"

can someone help me with this error?

User avatar
John
Posts: 205
Joined: 11 Apr 2013, 08:31
Location: UK
Contact:

Re: phpBB Gallery 3.0.12

Postby John » 25 Mar 2014, 15:22

Not sure why this happens but if you open the file install_install.php in the install folder and delete

Code: Select all

      if ($user->data['user_type'] != USER_FOUNDER)
      {
         trigger_error('FOUNDER_NEEDED', E_USER_ERROR);
      }

Then you should be good to go.

BadCompany
Posts: 2
Joined: 08 Jun 2014, 02:54

Re: phpBB Gallery 3.0.12

Postby BadCompany » 08 Jun 2014, 02:57

Hi, thanks for fixing link for Automod, however after following instructions I get this error when trying to go to the gallery. My phpBB is at version 3.0.12. and I have the latest version of Automod installed.

Code: Select all

SQL ERROR [ mysql4 ]

Table 'database_name.phpbb_gallery_users' doesn't exist [1146]

SQL

SELECT * FROM phpbb_gallery_users WHERE user_id = 2

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/gallery/user.php
LINE: 67
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/gallery/user.php
LINE: 54
CALL: phpbb_gallery_user->load_data()

FILE: [ROOT]/includes/gallery/gallery.php
LINE: 69
CALL: phpbb_gallery_user->__construct()

FILE: [ROOT]/gallery/index.php
LINE: 20
CALL: phpbb_gallery::setup()

Any ideas?


Return to “Updated MODs”



Who is online

Users browsing this forum: No registered users and 1 guest